Problemas en registro Jomsocial, raro ayuda urgente¡

Diseña tu página web con Joomla ¡ En 6 pasos ! Foros Joomla 1.5 Componentes Problemas en registro Jomsocial, raro ayuda urgente¡

  • Este debate tiene 8 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 11 años, 1 mes por Anónimo.
Mostrando 8 respuestas a los debates
  • Autor
    Entradas
    • #84923
      Anónimo
      Invitado

      Saludos amigos se que este tema esta en un topic

      https://solojoomla.com/instalacion-configuracion-y-actualizacion-jomsocial.html

      Pero en serio ya probe los dos plugs, tambien cheque muchas veces el registro y estas son las dos cosas que estan pasando

      Al registrar un usuario, todo va bien hasta llegar al avatar, cuando llego ahi, ya no hay boton o link que diga finalizar o terminar, por tal razon ahi se queda uno. Sin embargo a esa altura el usuario ya ha sido creado en Mi joomla y jomsocial es decir el registro funciona pero nomas no encuentro como mandar algun mensaje de que el registro se realizo con exsito, sin emabrgo un correo es enviado al usuario solo por esto he tenido paciencia pero ya no puede seguir asi.

      Instale Sh404SEF y creo que un plug para Jomsocial, todo trabaja perfecto menos esta parte, el problema es que ya tenia problemas con mi registro desde antes segun algunos amigos me comentarion estos dias…

      El registro de usuarios debe estar activado en joomla, se puede hacer un registro “one step” para jomsocial, ¿como se hace?.. Y bueno lo mas importante como puedo configurar bien mi aplicacion para no sufrir por esto.

      Gracias y ojala alguien por ahi me pueda dar un tip :dry:

    • #84926
      redloModerador Foro
      Participante

      Hola colaborador plus 🙂 . Oye dime que version estas utilizando. Esto mismo me paso con la version 1.0.128 en otro dominio, solo fue cuestion de desintalar y volver a instalar, los datos no desaparecen, o sea que no se borran las tablas e informacion de la base de datos. Tambien seria bueno saber que modulo utilizas para el registro y acceso, ya que hay unos cuantos que no terminan de funcionar bien, el que nunca me a fallado con el registro y redireccionamiento es el de Yoo_Login.

      En cuanto al registro en un solo paso, si no estaria mal, pero entonces ¿de que te podria servir el jomsocial? Cambiate a Community Builder, ¿Lo has probado? es quizas lo que necesites.

    • #84927
      Anónimo
      Invitado

      Hola Redlo , pues mira tengo JS 1.2.2 uso el modulo yoo_login, y bueno desactive el sh404SEF y al parecer ya jala bien supongo que algun problema con el AJAX, esto me llevo a investigar y quiero saber si alguna mejora encontrare en ARTIO pero el plugin tambien tiene un costo no, asi que no se que hacer la verdad… Tambien tuve que desactivar el Sh404 en Kunena porque no estaba funcionando correctamente, jaja porque tampoco tengo el plugin, entonces realmente no era tan amigable la URL, de cualquier forma Kunena se indexa perfecto en google con o sin los SEF URLS

      Gracias Redlo.

    • #84928
      redloModerador Foro
      Participante

      Artio funciona muy bien y aun sigue teniendo versiones gratuitas, instalatelo no te arepentiras, el funcionamiento y aspecto desde el admin es practicamente identico. Para quitar los enlaces que se generan en todas las paginas y poder remplazarlo con otro enlace, el amigo xXossottoXx lo explica aqui perfectamente –> https://solojoomla.com/foro/componentes/como-quitar-el-mensaje-de-joomla-sef-urls-de-artio.html#5225 .

      Luego tambien puedes modificar el estilo, aqui tienes un ejemplo.

      [hide]$buf.=”.”.’D’.’e’.’s’.’a’.’r’.’r’.’o’.’l’.’l’.’o’.’s’.’

      ‘.’W’.’e’.’b’.’s’.’ ‘.’J’.’o’.’o’.’m’.’l’.’a’.’ ‘.’a’.’

      ‘.’M’.’e’.’d’.’i’.’d’.’a’.”.”;[/hide]

      Ya solo tienes que añadir el estilo en template.css, mas o menos asi

      #lk20 a{
      font-weight: bold;
      text-color: #7F9298;
      text-decoration: none;
      }

      #lk20 a:hover{
      font-weight: bold;
      background: #7F9298;
      text-color: white;
      text-decoration: underline;
      }

    • #84929
      Anónimo
      Invitado

      Es decir que no necesito el plugin genial lo intentare ahora mismo¡¡¡

      Otra cosa Redlo por ultimo, el .htaccess que venia default con joomla funciona bien con el sh404SEF al quitarle el .txt

      Pero cuando edito este archivo para incluir
      * php_value upload_max_filesize 10M
      * php_value post_max_size 20M

      Automaticamente marca error 500 internal server error. =( porque?

      Como puedo configurar correctamente esta parte? nunca he podido antes y ahora es muy necesario permitir a los usuarios subir hasta 10 MB

      Saludos muchas gracias por todo y por cierto si uso ARTIO que pasa con mi .htaccess, lo quito lo dejo?, es igual en este sentido tambien al sh404SEF?

      Gracias hermano

    • #84930
      redloModerador Foro
      Participante

      Debes cambiar el contenido del .htaccess . Despues de instalarlo te muestra el codigo y si lo has obviado lo tienes accediendo al componente y en Documentacion lo tienes o tomalo directamente..

      ##
      # @version $Id: htaccess.txt 9975 2008-01-30 17:02:11Z ircmaxell $
      # @package Joomla
      # @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
      # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
      # Joomla! is Free Software
      ##

      #####################################################
      # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
      #
      # The line just below this section: 'Options +FollowSymLinks' may cause problems
      # with some server configurations. It is required for use of mod_rewrite, but may already
      # be set by your server administrator in a way that dissallows changing it in
      # your .htaccess file. If using it causes your server to error out, comment it out (add # to
      # beginning of line), reload your site in your browser and test your sef url's. If they work,
      # it has been set by your server administrator and you do not need it set here.
      #
      #####################################################

      ## Can be commented out if causes errors, see notes above.
      # Options +FollowSymLinks

      #
      # mod_rewrite in use

      RewriteEngine On

      # Uncomment following line if your webserver's URL
      # is not directly related to physical file paths.
      # Update Your Joomla! Directory (just / for root)

      # RewriteBase /

      ########## Begin - Joomla! core SEF Section
      #
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteCond %{REQUEST_URI} !^/index.php
      RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$ [NC]
      RewriteRule (.*) index.php
      RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
      #
      ########## End - Joomla! core SEF Section

      ########## Begin - Rewrite rules to block out some common exploits
      ## If you experience problems on your site block out the operations listed below
      ## This attempts to block the most common type of exploit `attempts` to Joomla!
      #
      # Block out any script trying to set a mosConfig value through the URL
      RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
      # Block out any script trying to base64_encode crap to send via URL
      RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
      # Block out any script that includes a tag in URL
      RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
      # Block out any script trying to set a PHP GLOBALS variable via URL
      RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
      # Block out any script trying to modify a _REQUEST variable via URL
      RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
      # Send all blocked request to homepage with 403 Forbidden error!
      RewriteRule ^(.*)$ index.php [F,L]
      #
      ########## End - Rewrite rules to block out some common exploits

      Luego todo esto es configurable. Puedes añadir restricciones y demas.

    • #84932
      Anónimo
      Invitado

      Perfecto, te menciono el problema esque creo que al GUARDAR en mi bloc de notas cometo algun error, porque al subirlo de nuevo el mismo archivo no funciona

      alguna especificacion o como logro editar este archivo, creo que no lo estoy haciendo de la manera correcta, saludos, de cualquer forma voy a instalar el ARTIO parece que hay mas documentacion.

      Tambien los plugs deberian ser libres, minimo para Kunena,

    • #84933
      redloModerador Foro
      Participante

      Es posible que debas contactar con tu hosting, sucede que en ocasiones aparecen problemas de incompatibilidad. Por ejemplo para el sh404sef en un panel plesk funciona perfectamente pero con Cpanel hay que realizar unos ajustes, como es el anular alguna orden.

      Ejemplo:
      Si tienen problemas en el visionado de las paginas, como por ejemplo que se les quede en blanco las paginas, desde la pagina principal, que no enlacen debidamente y demas, busquen dentro del archivo la siguiente cadena de texto –> Options +FollowSymLinks y añadan una armuadilla al principio, asi #Options +FollowSymLinks , el problema deberia quedar resuelto. Eso con sh404SEF.

      Y si es cosa de no guardar bien en la edicion pues, no se, pero en ocasiones cuando se edita con el mismo editor el mismo archivo, sucede que guarda en la cache la anterior edicion y crees que estas editando el correcto y sin embargo no es asi. No es normal pero a veces sucede. Descargate el .htacces a tu ordenador, metele el codigo, borra el archivo que esta en el server desde tu cliente ftp y sube el .htaccess como si fuera un archivo nuevo, sin actualizar. A ver si asi si te funciona.

    • #84934
      Anónimo
      Invitado

      Si, pues lo guarde como ANSI y ya funciono, estaba por default en UTF -8 y esa es la unica explicacion que encuentro pero en teoria segun yo no deberia de afectar al htaccess, en fin

      ya tengo el ARTIO trabajando es lo mejor de lo mejor¡¡¡¡¡ gracias Redlo ya todo trabaja correctamente al parecer, tengo que hacer pruebas pero se ve muy bien todo

      lo unico que me gustaria cambiar seria que en lugar de /jomsocial/mi-perfil apareciera /comunidad/mi-perfil, no tengo experiencia usando estos componentes pero me imagino que todo esta en custom redirects, algun tip o mejor dicho jajaja algo que deba recordar no hacer?,

      Gracias de nuevo redlo y todo va perfecto

Mostrando 8 respuestas a los debates
  • El foro ‘Componentes’ está cerrado y no se permiten nuevos debates ni respuestas.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad