Problema! Mi sitio muestra otro estilo de plantilla al no usar el WWW.

Diseño y Posicionamiento Web con Joomla Foros General Joomla en General Problema! Mi sitio muestra otro estilo de plantilla al no usar el WWW.

  • Este debate tiene 4 respuestas, 3 mensajes y ha sido actualizado por última vez el hace 12 años, 8 meses por Anónimo.
Mostrando 4 respuestas a los debates
  • Autor
    Entradas
    • #101226
      Anónimo
      Invitado

      Hola! El problema que me ocurre ahora es bastante extraño. Veran… tengo una plantilla Rockettheme en mi sitio. Todo bien, funciona de maravilla pero cuando se teclea http://sitio.com la plantilla se cambia de color. Todo el sitio sigue siendo el mismo pero de otro color! No se que pueda estar pasando ni por que tomara esa configuración tan extraña. Espero me ayuden a resolverlo! Muchas gracias!

    • #101227
      robertRobert
      Participante

      Hola, http://www.Rockettheme.com realiza sus plantillas con un framework llamado Gantry . Si accedes a Extensiones / Gestor de plantillas y a tu plantilla veras que puedes realizar cambios de forma directa en tu plantilla.

    • #101232
      Anónimo
      Invitado

      El problema no es con la configuracion de la plantilla! la plantilla esta configurada lo que pasa es que cuando no se usa el www extrañamente se cambia la configuracion de plantilla

    • #101233
      redloModerador Foro
      Participante

      Solucion sencilla. Edita el archivo .htaccess que tendras asi si tienes las URLs amigables activadas, y justo despues de RewriteEngine On inserta este codigo remplazando TUDOMINIO por el tuyo. Redireccionara de forma automatica cuando pongas sitio.com a http://www.tusitio.com y obtendras el beneficio de una mejor indexacion en los motores de busqueda, ya que en la actualidad puede ser tratado como dos dominios diferentes.

      ########## Inicio - redireccion a www

      RewriteCond %{HTTP_HOST} ^TUDOMINIO.com [NC]

      RewriteRule ^(.*)$ http://www.TUDOMINIO.com/$1 [L,R=301]

    • #101238
      Anónimo
      Invitado

      Muchas gracias Redlo! Resolviste mi problema. Aunque nunca termine de descubrir por que esto pasaba. Probé la pagina con otro dominio y esto no sucedía. Pero si tu dices que ayuda al SEO haré lo que tu dices

Mostrando 4 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Contiene enlaces a sitios web de terceros con políticas de privacidad ajenas que podrás aceptar o no cuando accedas a ellos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver
Privacidad