problema con URLs amigables Joomla 1.5

Diseño y Posicionamiento Web con Joomla Foros General Joomla en General problema con URLs amigables Joomla 1.5

  • Este debate tiene 2 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 12 años, 7 meses por Anónimo.
Mostrando 2 respuestas a los debates
  • Autor
    Entradas
    • #101503
      Anónimo
      Invitado

      ¡Hola a todos amig@s de Joomla!

      Llevo poco más de 24 horas tratando de resolver este problemita revisando foros y leyendo un poco y haciendo pruebas pero sin ningún resultado aún. Resulta que quiero hacer las URLs de mi site más amigables, para esto me dirijo a configuración global y activo las URLs amigables; ¡perfecto! las URLs cambian y el site funciona un 97% excelente a excepción de 3 (tres) links internos en el site que me llevan a un error 404 de página no encontrada. Tengo dentro del site varios links internos que ayudan al usuario a navegar entre artículos del contenido y son solamente tres los links que me lanzan este error.
      Revisando foros me encuentro que debo cambiar htacces.txt por .htacces y configurar algunas líneas dentro de el. De entre las líneas que modifiqué fueron estas:

      por defecto:
      Options +FollowSymLinks

      modificada:
      #Options +FollowSymLinks

      por defecto:
      # RewriteBase /

      modificada:
      RewriteBase /

      Solamente estas dos líneas modifiqué, cambié el nombre del archivo por .htacces y subí al directorio raíz; debo resaltar que en ningún foro he leído que al renombrar este archivo, se deba eliminar del directorio raíz el archivo original htacces.txt; de todas maneras hice pruebas con el y sin el; pero el resultado sigue siendo el mismo, el site sigue funcionando con sus URLs amigables pero solo un 97% y los mismos links siguen lanzando el error 404. También activo apache mod_rewrite (utilizo servidores linux).

      ¿Que puedo instalar un módulo? si pero en que me va a cambiar un módulo si son solamente tres links los que no quieren imprimir el resultado, he creado artículos nuevos para que cambie la URL final y aún así sigue pasando lo mismo.

      ¿Qué estaré pasando por alto?

      Agradezco cualquier ayuda de antemano
      Gracias

    • #101534
      robertRobert
      Participante

      No se si es que lo has escrito mal o realmente lo tienes asi, el archivo es .htaccess con doble s al final, nunca se sabe 🙂 . ¿Puedes indicar con que estan relacionados los enlaces del error404?

    • #101553
      Anónimo
      Invitado

      Bien Robert aquí escribí mal el nombre del archivo pero en el directorio está bien escrito

      adjunto una captura de lo que me aparece en ves de mi artículo indicando el error 404 que me aparece.

      como dato curioso muestro esto:

      este es un link normal sin activar las URLs amigables:
      http://www.dominio.org/index.php?option=com_content&view=article&id=38&Itemid=10”

      así aparece cuando activo las URLs amigables y me imprime el error 404:
      http://www.dominio.org/eventos/38”

      ahora para los links internos (que son varios) escribo el título del artículo o un texto “leer más…” y tengo en el gestor de menús uno especialmente dedicado para seleccionar el artículo a utilizar, hago esto solo para copiar y pegar el link en el texto del título del artículo o en leer más ya que no se por qué la función que trae Joomla de leer más no me funciona, al darle clic al leer más el artículo me imprime solo hasta donde le coloqué la línea del leer más.
      Bien pero mi caso son solamente estos tres dichosos links, todos los demás me corren bien.

      así se ve el link copiado desde el menú de prueba:
      “index.php?option=com_content&view=article&id=38”

      y me aparecen en el navegador como ya lo puse arriba,
      ahora así se ven los otros links que si corren bien con las URLs amigables:
      http://www.dominio.org/eventos/9-eventos/25-eventos”

      hay una gran diferencia entre esto y
      http://www.dominio.org/eventos/38”

      y los dos pertenecen a las mismas secciones y eventos 🙁

      si necesitas mas datos házmelo saber por favor y gracias por tu ayuda

Mostrando 2 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Contiene enlaces a sitios web de terceros con políticas de privacidad ajenas que podrás aceptar o no cuando accedas a ellos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver
Privacidad