Problema al enviar mail en el ps_order.php

Diseño y Posicionamiento Web con Joomla Foros Joomla 1.5 Componentes Problema al enviar mail en el ps_order.php

  • Este debate tiene 5 respuestas, 1 mensaje y ha sido actualizado por última vez el hace 13 años, 7 meses por Anónimo.
Mostrando 5 respuestas a los debates
  • Autor
    Entradas
    • #94401
      Anónimo
      Invitado

      En el back, en la lista de pedidos cuando cambio a uno el estado, marco ‘notificar al cliente’ y le doy a ‘actualizar estado’, pero no envía ningún correo y sale arriba el error:

      Notice: Trying to get property of non-object in …Joomlaadministratorcomponentscom_virtuemartclassesps_order.php on line 456

      ¿Sabe alguien porqué puede estar pasando esto?

      Gracias

    • #94404
      Anónimo
      Invitado

      Laura78 escribió:

      …..administratorcomponentscom_virtuemartclassesps_order.php on line 456….

      Hola

      Que dice esa línea?

    • #94406
      Anónimo
      Invitado

      Hola, muchas gracias por contestar. Dice:

      $vmLogger->warning( $VM_LANG->_(‘PHPSHOP_DOWNLOADS_ERR_SEND’,false).’ ‘. $db->f(“first_name”) . ” ” . $db->f(“last_name”) . “, “.$db->f(“user_email”).” (“. $result->ErrorInfo.”)” );

    • #94410
      Anónimo
      Invitado

      Ahora he cambiado los parámetros de configuración global > servidos > configuración de correo y me envía bien los emails de recomendación de un artículo y también los de resgistro de un usuario nuevo, pero no llegan ni los de terminar un pedido ni los de cambiar el estado de un pedido.

      En tienda > admon > configuración > envío, tengo señalado sólo el ‘Modulo estándar del envío con configuracíon individual del transporte y tarifa. ¡RECOMENDADO!’

      Ya no sé que más mirar…

      Por cierto, ahora al cambiar el estado de un pedido me da errores también en otro fichero:

      Notice: Undefined variable: mosConfig_smtpport in C:wampwwwcarlosJoomlaadministratorcomponentscom_virtuemartclassesps_main.php on line 506

      Notice: Undefined variable: mosConfig_smtpsecure in C:wampwwwcarlosJoomlaadministratorcomponentscom_virtuemartclassesps_main.php on line 507

      que corresponden a las variables del puerto y de la seguridad SSL respectivamente, pero repito, los emails de recomendación de un artículo y también los de resgistro de un usuario se envían perfectamente.

      ¿Alguna idea?

    • #94411
      Anónimo
      Invitado

      Laura78 escribió:


      Notice: Undefined variable: mosConfig_smtpport in C:wampwwwcarlosJoomlaadministratorcomponentscom_virtuemartclassesps_main.php on line 506
      Notice: Undefined variable: mosConfig_smtpsecure in C:wampwwwcarlosJoomlaadministratorcomponentscom_virtuemartclassesps_main.php on line 507…

      Ciao

      Estás en local!!! podías haber empezado por ahì!!!
      SEn local tendrás todos los problemas del mundo con el correo, porque no está configurado el servidor de correo.

    • #94437
      Anónimo
      Invitado

      muchas gracias, aunque aún me salen otros dos errores en la pantalla “Terminar pedido”, justo antes del mensale “Gracias por su pedido” y la palomilla de correcto:

      Deprecated: Function ereg_replace() is deprecated in C:wampwwwadministratorcomponentscom_virtuemartclassesps_checkout.php on line 1019

      Notice: Undefined property: ps_payment::$payment_code in C:wampwwwadministratorcomponentscom_virtuemartclassesps_checkout.php on line 1191

      en esas lineas el código es:

      1019 $payment_number = ereg_replace(” |-“, “”, @$_SESSION[‘ccdata’][‘order_payment_number’]);

      1191 if( $enable_processor == “Y” || stristr($_PAYMENT->payment_code, ‘_API’ ) !== false ) {

      los momentarios encima de ellas son:

      1019 * Insert the Order payment info

      1191 // Now as everything else has been done, we can update
      // the Order Status if the Payment Method is
      // “Use Payment Processor”, because:
      // Payment Processors return false on any error
      // Only completed payments return true!

      No sé por donde agarrarlo! 🙁

Mostrando 5 respuestas a los debates
  • El foro ‘Componentes’ está cerrado y no se permiten nuevos debates ni respuestas.
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Contiene enlaces a sitios web de terceros con políticas de privacidad ajenas que podrás aceptar o no cuando accedas a ellos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver
Privacidad