Modulo Buscar en Joomla 3.4.8

  • Este debate tiene 9 respuestas, 3 mensajes y ha sido actualizado por última vez el hace 8 años por lorena28lorena.
Mostrando 9 respuestas a los debates
  • Autor
    Entradas
    • #115306
      neos76Emilia J.
      Participante

      Tengo una plataforma en preproducción con un portal joomla 3.4.8 con la plantilla por defecto Protostar. He añadido el módulo de búsqueda y lo he configurado para que éstas se lleven a cabo sólo en artículos. Pues bien, el inconveniente viene al efectuar una consulta en la que intervienen palabras con acento, produciéndose los siguientes resultados:

      Al buscar sin acento, encuentra las palabras (acentuadas o no) del título y las palabras no acentuadas del contenido
      Si busco palabras con acento, sólo encuentra las palabras (acentuadas o no) del título, pero ninguna en el contenido (estén o no acentuadas)

      Como podría solucionarlo?

    • #115309
      alex99Alex
      Participante

      El problema puede estar en la plantilla. Comprueba que incluye el charset UTF-8. Algo asi…

    • #115310
      neos76Emilia J.
      Participante

      Gracias alex99… He comprobado que la etiqueta meta ya existe en el index principal, pero no en el de la plantilla. Se la añadí en este último y ahora aparecen 2 al cargar la pagina y sigue ocurriendo lo mismo… pasa incluso con las plantillas incluidas en la instalación inicial 🙁

    • #115313
      alex99Alex
      Participante

      Accede a Extensiones / Idiomas y dime si tienes el Idioma de contenidos creado para el Español.

    • #115314
      neos76Emilia J.
      Participante

      Efectivamente… no lo tengo. Solo aparece Ingles… Pero si que esta instalado en la plataforma (tanto para sitio como para administracion).
      Lo he intentado agregar utilizando el boton de “Instalar idioma” pero no se encuentra disponible. Como puedo instalarlo?

    • #115316
      alex99Alex
      Participante

      Accedes Extensiones / idiomas y haces clic en Idiomas del contenido a la izquierda de tu pantalla, y despues al boton Nuevo. Y le pones las etiquetas como en la captura siguiente, o te fijas en el ingles editandolo.

    • #115317
      neos76Emilia J.
      Participante

      Lo hice… pero sigue la misma situación. Para probar cambié el idioma de un artículo (de Todos a Spanish) pero sigue sin buscar bien. 🙁

    • #115318
      lorena28lorena
      Participante

      Hola, ¿Cómo dices que has configurado el buscador en joomla 3.x? . Explica donde has limitado la busqueda solo a articulos.

      Nunca me habia fijado, pero e ido a Componentes / Buscar y ahí no dice nada de limitar las busquedas en ese sentido. En el módulo tampoco.
      Si, hay plugins de extensiones que incluyen la posiblidad de realizar busquedas al mismo tiempo desde el buscador joomla.

      No termino de entender bien que quieres decir con esa limitación.

    • #115320
      neos76Emilia J.
      Participante

      Si… puede que no me haya explicado bien… soy bastante novato 🙂 La forma en que he ajustado las búsquedas sólo a los contenidos es a través de extensiones plugins… He localizado las referencias a buscar y aparece como la imagen… Solo dejando publicado Contenido entiendo que sólo hace las búsquedas en ese tipo.

      Attachments:
    • #115338
      lorena28lorena
      Participante

      ¿ Lo que te instalaste fue el pack original de joomla o un quickstart de una plantilla ? Si esta online, indica la URL:

      Saludos

Mostrando 9 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Contiene enlaces a sitios web de terceros con políticas de privacidad ajenas que podrás aceptar o no cuando accedas a ellos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver
Privacidad