K2 no se ven las imágenes en los articulos

Diseño y Posicionamiento Web con Joomla Foros General Joomla en General K2 no se ven las imágenes en los articulos

  • Este debate tiene 8 respuestas, 3 mensajes y ha sido actualizado por última vez el hace 10 años por TximeletaJuan.
Mostrando 8 respuestas a los debates
  • Autor
    Entradas
    • #111790
      TximeletaJuan
      Participante

      Un saludo:
      Hace muy poco que me he lanzado a usar el componente K2, pues creo que me puede ayudar a hacer la página web con más posibilidades. Uso la plantilla puri III y las ultimas versiones de Joomla 3 y K2.
      Cuando he exportado desde joomla a K2 todo ha salido bien a no ser que cuando voy al sitio las imágenes de los artículos no se ven. Cuando abro el articulo desde la administración las imágenes se ven.
      He probado con artículos nuevos y pasa lo mismo nos se ven las imágenes.
      A la espera de alguna pista
      Gracias.

    • #111791
      alex99Alex
      Participante

      ¿Puedes facilitar la URL de la pagina a en cuestión? .

      El componente K2 trabaja con la libreria Mbstring de php y pueden suceder este tipo de errores si no la tienes instalada o activada.

      Otras posibilidades son revisar la ruta de esas imagenes y asegurarte que no tienes ningun plugin generador de miniaturas.

    • #111820
      TximeletaJuan
      Participante

      Gracias alex99
      He mirado en la configuración del PHP y no aparece la librería que me comentas, tendría que añadir al php algún parámetro? puede ser este?
      –enable-mbstring
      o tengo que instalar la librería ¿cómo se haría? en esto no tengo mucha idea.
      Las pruebas las podría hacer en Xamp
      Mi versión de PHP es 5.3.3
      La plantilla Puri III
      la Web es
      diaconos.es
      todavía no esta operativa te la abro unos días para que puedas verla
      Esta en un servidor virtual que controlo con Parallels panel.
      Las imagenes las cojo de las carpetas de image del joomla, las subo y luego las inserto.
      yo no he instalado ningún plugin generador de miniaturas
      Muchas gracias por tu paciencia de antemano

    • #111825
      lorena28lorena
      Participante

      Si, pero primero, limpia el código del texto que no sirve. En esta url > http://diaconos.es/index.php/item/1309-cual-es-el-lugar-del-diaconado-permanente-en-la-iglesiase aprecia que hay código inservible que solo molesta, ya que si comparas con la web de inicio, veras que el modulo k2 tools, se desplaza hacia la parte inferior de tu pagina y es debido a eso mismo.

      Luego para activar MBstring, accede al archivo php.ini de tu servidor y comprueba que las referencias al mismo, no estan comentadas. Si lo estuvieran, debes acceder al servidor, activarlo y compilar la version de tu PHP. Luego reiniciar el Apache (Solo para asegurarte) . Si sigue sin funcionar, debes descomentar (Quitar el punto y coma – ; – del principio de la cadena a activar) las referencias a mbstring y reiniciar el Apache y ya tendrias las librerias MBstring activadas.

      Y pasate a Easyphp es mucho mas comodo (Al menos para mi) y no te da algunos problemas que surgen con XamPP

    • #111837
      TximeletaJuan
      Participante

      Para limpiar el codigo ¿basta con cambiar el alias del item? yo lo he dejado así pero pasa lo mismo
      http://diaconos.es/index.php/item/1309-1
      Lo otro lo voy a intentar
      Gracias lorena28

    • #111838
      lorena28lorena
      Participante

      No, para limpiar el codigo que se enconde detras de los textos que has publicado, tienes que acceder al articulo y debes seleccionar TODO el texto y copiarlo a un editor como por ejemplo, el notepad de windows.
      Asi consigues eliminar estilos no deseados entre otros.

      Vuelves a copiar, esta vez desde notepad de windows, y lo pegas de nuevo al editor joomla, no sin antes eliminar por completo el texto que habia con el código molesto e inservible. Guarda y compruba que el modulo se vuelve a su sitio correcto.
      Despues, si tenias palabras de algun color o señeladas en negrita, saltas de texto y demas, lo ajustas desde el mismo editor de joomla.

      Con eso bastara para el tema del desplazamiento del módulo.

    • #111840
      TximeletaJuan
      Participante

      Gracias Lorena28.
      Osea que son los codigos que arrastramos en el articulo cuando copiamos y pegamos directamente , por ejemplo,.desde una web. Creo que lo he entendido.
      Me sigo peleando con lo de mbstring
      gracias

    • #111843
      lorena28lorena
      Participante

      Desde una web o desde un Word, asi es, correcto. Otra cosa mas, es el separador de texto de introducción y el texto completo. Lo que se llama el tipico “LEER MÁS” situado bajo el editor.
      Si JUSTIFICAS el texto, hazlo por parrafos y no todo el texto, y mas si hay una linea de separación de este tipo, ya que si cierras el parrafo o la division despues de la etiqueta ..



      Sucede que tambien se desmonta todo y ya te puedes volver loc@ hasta dar con la tela 😉

    • #111845
      TximeletaJuan
      Participante

      Gracias
      Yo he seguido tu consejo y me he instalado Easyphp y he puesto la página para investigar.
      he Encontrado el php.ini
      he visto que tiene la libreria esta.
      pero luego todo lo que está debajo de
      [mbstring]
      esta con ; creo que eso lo desactiva te adjunto archivo pdf

      Tengo que quitar ;?
      a la espera

      Attachments:
Mostrando 8 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Contiene enlaces a sitios web de terceros con políticas de privacidad ajenas que podrás aceptar o no cuando accedas a ellos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver
Privacidad