De repente a veces dice error “No se ha enviado ningún dato”

Diseña tu página web con Joomla ¡ En 6 pasos ! Foros General Mi web Joomla De repente a veces dice error “No se ha enviado ningún dato”

Mostrando 22 respuestas a los debates
  • Autor
    Entradas
    • #116354
      MargaritaSMargarita
      Participante

      Estoy trabajando, traduciendo los campos del menú de jomsocial y varias veces me ha pasado que de repente me aparece un pantallazo en blanco con el error “No se ha enviado ningún dato” :S y al cabo d eunos inutos si refrescro sigue funcionando la web. ¿Por qué pasa eso?

    • #116356
      MargaritaSMargarita
      Participante

      A veces tarda a cargarse cuando intento navegar por las secciones del menú del jomsocial y me da el siguiente error:
      ————————————-
      La página dominio.com no funciona

      dominio.com no ha enviado ningún dato.
      ERR_EMPTY_RESPONSE

      cargar de nuevo
      ——————————————————–

      Le doy a cargar de nuevo y se carga.

      No es normal que vaya tan lento y dé esos mensajes de errores. El servidor es linux.

    • #116362
      redloModerador Foro
      Participante

      Jomsocial debe tener el servidor configurado con los limites ajustados para el mismo. Si no, te dara problemas. Normalmente no es muy relevante, pero si esos limites estan muy bajos (Por decirlo de algún modo) sucede lo que comentas.
      Sucede también en modo general que el módulo de la vista de los usuarios, ralentiza sobre manera la página en donde se encuentra.

    • #116365
      MargaritaSMargarita
      Participante

      Al instalarlo me salieron todos los ticks verdes, ¿cómo puedo saber qué hay que cambiar de la configuración para que no dé estos errores?

      Te refieres a que cuando más usuarios hay ¿más lento irá?

    • #116369
      redloModerador Foro
      Participante

      No, no me refiero a la cantidad de usuarios, solo a ese módulo en concreto. Viene de muy atras el problema, y es por lo que he comentado en mi respuesta anterior, que jomsocial no esta del todo integrado en joomla.
      Si te refieres a que los usuarios se puedan enviar mensajes entre si, debes configurar el CRON Job de tu servidor.

      Saber mas sobre CRON Job.

    • #116375
      MargaritaSMargarita
      Participante

      He abierto el archivo cronjob.php y dice lo siguiente:

      ¿Tengo que borrar alguna línea por lo que dice de “remove”? y ¿tengo que escribir mi dominio 2 veces en donde dice “yoursite.com? ¿sin las http://www.?

      <?php

      /**

      * @copyright (C) 2013 iJoomla, Inc. - All rights reserved.

      * @license GNU General Public License, version 2 (http://www.gnu.org/licenses/gpl-2.0.html)

      * @author iJoomla.com

      * @url https://www.jomsocial.com/license-agreement

      * The PHP code portions are distributed under the GPL license. If not otherwise stated, all images, manuals, cascading style sheets, and included JavaScript *are NOT GPL, and are released under the IJOOMLA Proprietary Use License v1.0

      * More info at https://www.jomsocial.com/license-agreement

      */

      // !!!IMPORTANT!!! Remove this line for the script to work

      defined('_JEXEC') or die('Restricted access');

      // Change the $hostname to your site's URL

      $hostname = 'yoursite.com';

      // If you have subfolder on your main site, specify it here. Should not end or begin with any trailing slash.

      $subfolder = '';

      if ($hostname == 'yoursite.com')

      {

      return;

      }

      $resource = @fsockopen($hostname, 80, $errorNumber, $errorString);

      if ( ! $resource)

      {

      echo 'Error connecting to host';

      return;

      }

      $output = "GET /" . $subfolder . "/index.php?option=com_community&task=cron HTTP/1.1rn";

      $output .= "Host: " . $hostname . "rn";

      $output .= "Connection: Closernrn";

      fwrite($resource, $output);

      fclose($resource);

      echo "Cronjob processed.rn";

      return;

    • #116377
      MargaritaSMargarita
      Participante

      En el C-panel tengo la opción “Tareas cron para configurar” ¿Qué tiempo me aconsejas que ponga en cada apartado?

      Aquí pantallazo de las casillas que tengo para rellenar:

      http://www.image-share.com/ijpg-3452-117.html

    • #116384
      redloModerador Foro
      Participante

      Cada hora o cada dos horas, dependiendo del trafico que tengas.

    • #116385
      redloModerador Foro
      Participante

      No tienes que borrar nada, y si, remplazalo por tu dominio.

      [quote=”MargaritaS” post=36477]He abierto el archivo cronjob.php y dice lo siguiente:

      ¿Tengo que borrar alguna línea por lo que dice de “remove”? y ¿tengo que escribir mi dominio 2 veces en donde dice “yoursite.com? ¿sin las http://www.?

      <?php

      /**

      * @copyright (C) 2013 iJoomla, Inc. - All rights reserved.

      * @license GNU General Public License, version 2 (http://www.gnu.org/licenses/gpl-2.0.html)

      * @author iJoomla.com

      * @url https://www.jomsocial.com/license-agreement

      * The PHP code portions are distributed under the GPL license. If not otherwise stated, all images, manuals, cascading style sheets, and included JavaScript *are NOT GPL, and are released under the IJOOMLA Proprietary Use License v1.0

      * More info at https://www.jomsocial.com/license-agreement

      */

      // !!!IMPORTANT!!! Remove this line for the script to work

      defined('_JEXEC') or die('Restricted access');

      // Change the $hostname to your site's URL

      $hostname = 'yoursite.com';

      // If you have subfolder on your main site, specify it here. Should not end or begin with any trailing slash.

      $subfolder = '';

      if ($hostname == 'yoursite.com')

      {

      return;

      }

      $resource = @fsockopen($hostname, 80, $errorNumber, $errorString);

      if ( ! $resource)

      {

      echo 'Error connecting to host';

      return;

      }

      $output = "GET /" . $subfolder . "/index.php?option=com_community&task=cron HTTP/1.1rn";

      $output .= "Host: " . $hostname . "rn";

      $output .= "Connection: Closernrn";

      fwrite($resource, $output);

      fclose($resource);

      echo "Cronjob processed.rn";

      return;
      [/quote]

    • #116437
      MargaritaSMargarita
      Participante

      [quote=”redlo” post=36486]Cada hora o cada dos horas, dependiendo del trafico que tengas.[/quote]

      Si tendré muuucho tráfico ¿qué hago para prevenirlo?

    • #116438
      MargaritaSMargarita
      Participante

      De momento he modificado el archivo cronjob.php añadiendo mi web la primera vez que lo pide. En tareas cron he elegido dos veces cada hora y he añadido el comando para c-panel. Pero sigo con el problema error.

      Ya aumenté los límites de PHp según lo requerido paar Jomsocial.

      Ayyy… :S

    • #116439
      MargaritaSMargarita
      Participante

      En el hosting algunos valores están limitados y sólo puedo elegirlos desde un desplegable, así que los valores recomendados por jomsocial los he puesto en el archivo php.ini, a ver si ahora funciona.

    • #116458
      redloModerador Foro
      Participante

      Vale, avisa a ver que tal.

    • #116470
      MargaritaSMargarita
      Participante

      Como seguía con el error, tuve que pagar 28.99 € para que el hosting me modificara los siguientes valores porque el servidor es compartido:

      memory_limit from 512M to 1024M
      post_max_size from 128M to 1024m
      upload_max_filesize 1G

      Pero… sigo con el mismo error.

      Es un error que sólo aparece dentro de JomSOcial y no en joomla, porque por la web hecha en jomla puedo navegar tantranquilamente, es al querer navegar por JomSocial, por ejemplo al clicar en “perfiles” de repente me aparece ése error. Los del Hosting han entrado en Jomsocial con un usuario que tengo de prueba y me dicen que no es por culpa del hosting (y puede ser porque por la web hecha con Joomla sí que puedo navegar sin ningún problema), me dicen que es problema de un script, que prueba de actualizar joomla. Así que les pediré a los d eJomSocial que me miren ellos dónde está el fallo, porque es debido a JomSocial.

      No quiero actualizar Joomla para perder todo lo que está hecho hasta ahora cuando Joomla me funciona correctamente.

    • #116489
      MargaritaSMargarita
      Participante

      Los de JomSocial me han dicho lo siguiente:

      “[i]This issue caused by your server is not stable, that error usually caused by server issue. Anyway, please you try upgarde your PHP version to 5.6.x or 7.x

      You are using old Jomsocial and Joomla version, i suggest you update it them.

      Thank you[/i]”

      O sea, que dicen que tengo una versión antigua de Jomsocial y es la más cara que tuve que pagar. Si la actualizo ¿perderé todo lo que he hecho?

      Y si actualizo la versión de Joomla ¿voy a perder todo lo que tengo hecho?

    • #116492
      MargaritaSMargarita
      Participante

      Acabo de ver la siguiente advertencia dentro de joomla ¿será ésta la solución? Lo que pasa es que no entiendo qué me dicen que debo hacer.
      “La carpeta temporal de PHP no ha sido asignada.
      La carpeta temporal de PHP es la carpeta que PHP usa para almacenar los archivos subidos, antes de que Joomla pueda acceder a ellos. Si el directorio ha sido asignado, no debería ser un problema, pero, si está teniendo problemas con archivos que no están siendo detectados, o archivos subidos que no están siendo detectados, definir esto en su archivo ‘php.ini’ podría solucionar el asunto.”

    • #116501
      redloModerador Foro
      Participante

      Mira el permiso de escritura de la carpeta /tmp dentro de tu joomla.

      Saber Más. Lee a partir de Permisos de Lectura y Escritura – CHMOD

    • #116529
      MargaritaSMargarita
      Participante

      Gracias! Mañana lo miro y te digo.

    • #116544
      MargaritaSMargarita
      Participante

      La carpeta /tmp tenía los permisos 755 y le he dado permisos 777. A ver si así funciona. Porque los de soporte de JomSocial me dicen que actualice la versión de JomSocial pero no quiero perder todas las preguntas personalizadas del registro.

    • #116545
      MargaritaSMargarita
      Participante
    • #116547
      MargaritaSMargarita
      Participante

      He actualizado JomSocial y sigo con el error :(. Me he fijado al instalar JomSocial que tengo que aumentar en la configuración de MySQL el valor “wait_timeout” y el valor “connect_timeout”, porque JomSocial recomienda el valor 120 y el valor actual es 60 ¿cómo puedo cambiarlo desde PHPMyAdmin?

    • #116550
      MargaritaSMargarita
      Participante

      Uno de los requisitos que me piden en JomSocial es que los valores “Wait_timeout” y “connect_timeout” de MySQL sean 120 y por defecto en el servidor compartido son 60. He pedido al hosting aumentar esos valores y de las 3 personas distintas que me han atendido, la última me ha dicho que el servidor compartido no puede soportar más de 60 que tengo que pasarme a un servidor dedicado muuucho más caro, me siento engañada porque las otras dos personas que me atendieron no me dijeron nada de eso.

      ¿Puede funcionar JomSocial con “Wait_timeout” y “connect_timeout” a 60 en el caso de que no pueda pasarlo realmente a 120? 🙁

    • #116556
      redloModerador Foro
      Participante

      Respuesta corta… SI 🙂 es solo una recomendación. De hecho acabo de probar el formulario, y me ha llegado todo correcto.

      Podrias crear un archivo php.ini y colocarlo en la raiz de tu joomla, a veces funciona. O directamente cambiar esos valores desde el archivo .htaccess (O sea, punto htaccess) si es que lo tienes asi. Si lo tienes como htaccess.txt debes renombrarlo para poder añadir los cambios y que sean efectivos.

      Luego todo cambio a nivel servidor, implica que se tenga que reiniciar el apache para que los cambios sean tomados.

Mostrando 22 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad