AYUDA para Insertar un html local en un articulo o menú

Diseño web Joomla Foros General Mi web Joomla AYUDA para Insertar un html local en un articulo o menú

Mostrando 10 respuestas a los debates
  • Autor
    Entradas
    • #109215
      yonguerdavid
      Participante

      Hola Buenas a todos. Mi problema es el siguiente:

      En uno de los menus de mi web necesito insertar un articulo con 1 JPG a traves del cual se pueda acceder a 2 pag diferentes, a ese mismo jpg le he creado 2 sectores en photoshop con el link correspondiente a cada web y lo guardo para web y photoshop me crea un HTML. Al abrirlo con el navegador me aparece mi JPG y los 2 link funcionan correctamente.

      El problema es que la ruta del HTML es local, es decir file:///C:/Users/dyc/Documents/xxxxx.html, y no se como insertalo en mi web, o si primero lo tengo que subir por ftp, de ser así donde lo meto??? o crear una pag embebida (en este caso me dice que no encuentra el archivo en el servidor, por otra parte lógico ya que está en mi PC no en el servidor), o si hay algún tipo de pluging para insertar HTML en articulos.

      No controlo muy bien todo el tema de código… a si que estoy bastante perdido.

      a ver si alguien me puede ayudar.

      gracias de antemano.

      un saludo.

    • #109216
      chavezzRuddy
      Participante

      Lo mas practico creo seria que ese HTML que te genera Photoshop lo subas por FTP a la raiz de tu sitio, luego creas tu menu con la opcion Wrapper de Joomla y colocas alli la URL de tu HTML, me imagino que ese HTML que te genera Photoshop tambien te genera una carpeta donde estan las imagenes, si es asi tambien sube dicha carpeta en el mismo directorio raiz donde subas el HTML.

      NOTA:
      Si la carpeta que que te genera Photoshop con las imagenes se llama “images” no es necesario que la subas ya que existe una ya en Joomla, solo sube las imagenes.

    • #109217
      yonguerdavid
      Participante

      Gracias por la respuesta, de verdad.

      lo hago en un rato y te digo si lo he conseguido.

    • #109222
      yonguerdavid
      Participante

      hola de nuevo Chavezz…

      he subido el html a la raiz del servidor…. y he copiado las images a la carpeta de images de joomla…

      he creado el menú con la opción wrapper… y al ponerle la url del archivo html… en el navegador me aparece la pagina entera, no el archivo en cuestión.
      esta sería la url???? el problema esta en que el html está junto con el index php en la raiz del servidor?????

      http: // mipagina.com / archivo.html

    • #109223
      chavezzRuddy
      Participante

      Unas consultas:

      • Que version de Joomla usas?

      • Puedes brindarme la URL del HTML que subiste a la raiz para ver su estructura?

    • #109228
      yonguerdavid
      Participante

      Hola buenos días.

      uso la 2.5 de joomla.

      Esta es la web: http://www.sculptorsiluette.com

      En el menú inicio debería aparecer el html que enlaza a los otros 2 menús y no la pag en contrucción de 1and1.

      [url=http://www.sculptorsiluette.com/inicio.html[/url] en teoria esta es la url del html subido en la raiz del servidor.

      todos los archivos joomla estan dentro de una carpeta llamada app5774…… y el index y el html en cuestión estan en la raiz fuera de esa carpeta, y luego hay otra que pone LOGS. he intentado meter el html dentro de la carpeta de joomla, pero no me deja….

      Puede ser que no creara correctamente el html en photoshop??????

    • #109237
      chavezzRuddy
      Participante

      Ok, te la voy a poner mas facil, baja el .zip que te adjunto, descomprimelo, adentro hay un archivo llamado home.html, ese subelo a la raiz de su Sitio por FTP, para confirmar si lo subiste bien deberias de poder verlo despues en esta URL http://www.sculptorsiluette.com/home.html

      Luego cambia el Tipo de Elemento del Menu de Inicio por una URL embebida, para ello te adjunto unas imagenes para que lo hagas paso a paso.

      Con eso ya deberias de ver tus imagenes en la pagina de inicio del Sitio y no la de 1and1.

      De igual manera cualquier duda me comentas sin pena y vemos que paso, saludos…

    • #109243
      yonguerdavid
      Participante

      Nada no hay manera, al introducir esta URL http://www.sculptorsiluette.com/home.html en un primer momente en la pestaña del navegador aparece “error 404 no found” y automaticamente se carga la de 1and1….

      he probado una pag externa en el menú wrapper y funciona perfectamente, y el html home está correcto xq de forma local funciona perfectamente, osea que el problema está en el servidor… que por algún motivo no deja cargar el html.

      te agradezco mucho la ayuda… pero ya no se que más intentar…

      voy a dejar un articulo con el jpg fijo mientras tanto.

      gracias por todo…. te dejaría entrar en el servidor…para que la revisaras pero la pag no es mia y no puedo…..

      como puedes ver en la captura 2 se ve la raiz del servidor… y la pag de joomla se encuentra en la carpeta que pone app4649…. (captura 1). Yo creo que el problema está en que el html home debería de estar dentro de esta carpeta…. pero no me deja subirla, me sale el mensaje “550 home.html: Permission denied”.

      En alguna subcarpeta de esta…. si que me deja subir el archivo… pero no parece harcer nada…

      Attachments:
    • #109245
      chavezzRuddy
      Participante

      Me imagino las carpetas no tienen permiso de escritura, pero para darte una solucion mas practica entra al articulo de inicio donde ahora tienes tu imagen fija y entra en modo edicion de HTML y borra el codigo que veas alli y reemplazao por este:



      Si no sabes como entrar en modo edicion HTML no dudes en preguntar, con eso se mostrara tu imagen con los links hacia los otros articulos tal como lo quieres.

      NOTA: coloque URLs absolutas en el codigo porque me parece rara la estructura de tu Hosting donde guarda los archivos de Joomla, pero no debe afectar en nada.

      Cualquier otra duda sin pena, saludos…

    • #109254
      yonguerdavid
      Participante

      Hola de nuevo….

      al insertar el codigo en el articulo, me aparece así

      luego pinchando en cada recuadro donde deberían ir las fotos…. recargo todas las imagenes… y el articulo me queda así

      y en la web se ve así….

      las imagenes estan como descolocadas… y se ven los cortes entre ellas…..

      por que crees que será????.

      lo mismo es por las medidas de cada imagen que están en el codigo html?????

      voy a revisarlas una a una y compararlas con las que estan en la carpeta images.

      tambien voy a cambiar la ruta de cada imagen en vez de http://www.sculptorsiluette.com/images/… pongo la de http://www.sculptorsiluette.com/appp5373…./images/

      Muchas gracias de nuevo…. nos estamos acercando….

    • #109256
      chavezzRuddy
      Participante

      Algun descuadre a de ver con las celdas de la tabla, mejor usemos otro codigo, siempre entra a la edicion HTML y borra lo que esta y pega el codigo que esta en el archivo adjunto.

      El codigo usa la imagen completa que tienes ahora, asi que no la cambies de carpeta dejala donde esta, y para los Links use unos HotMap, los cuales mediante coordenadas dibuja un area sobre la imagen para volverla enlace.

      Con esto creo que ya no te dara problema, pero cualquier inconveniente no dudes en preguntar, saludos…

      Attachments:
Mostrando 10 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad