Adicionar Niveles de Acceso

  • Este debate tiene 2 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 9 años, 6 meses por Anónimo.
Mostrando 2 respuestas a los debates
  • Autor
    Entradas
    • #97650
      Anónimo
      Invitado

      Hola a Todos.

      Tengo el sig inconveniente y necesito algo de colaboración

      Resulta q estoy utilizando el componente CB para modificar el form de registro de los usuarios a mi pagina. En este form adicione un campo q se llama Tipo de Usuario y según el q escojan se clasifica el ingreso al portal, es decir, si yo me registro como Tipo de Usuario 1, solo tengo acceso a los menus x, y, z, pero si me registro como Tipo de Usuario 2, tengo acceso a los menus a, b, c.
      Inicialmente pense q todo era muy facil y solo necesitaba poder modificar el form de registro y x eso utilizo el CB, pero luego de tener listo el form, encuentro el problema q debo manejar niveles de acceso y ps para crearlos utilice NOIXACL pero tuve 2 problemas: 1. No supe como hacer para habilitar o deshabilitar los menús según el nivel de acceso y 2. Debia colocar el nivel de acceso del usuario por el backend y ps mi idea es q cuando el usuario se cree inmediatamente qde asignado el nivel de acceso según el tipo de usuario q seleccionó en el registro.

      Yo soy Ing de Sistemas y mi fuerte es la programación pero no quiero inventar la rueda, el problema es q no la encuentro y se q con un poco de ayuda la encontraré o al menos que me digan q no existe algo q haga lo q necesito y me toco hacer todo el proceso desde cero.

      Si no fui claro con mi inconveniente xfa me informan y buscare otra forma de hacerme entender.

      Gracias

      Fredy

    • #97673
      lorena28lorena
      Participante

      Community Builer 1.4.0 es compatible con Joomla 1.6. Con el CB en J!1.6 y el nuevo ACL de joomla 1.6 es probable que tengas exito, sin tener que depender de NoixACL que por otra parte hace mucho tiempo no actualizan y creo que aun esta en version Beta.

    • #97676
      Anónimo
      Invitado

      Muchas Gracias Lorena por constestar tan rápido. T cuento q yo tengo instalado Joomla 1.5 y en mi pag tengo una plantilla q es compatible con esta versión, por eso no he cambiado de versión. Voy a realizar pruebas xa ver si la plantilla es compatible con la versión 1.6 de Joomla, d ser así hago las pruebas q me dices. Der todas formas sigo en la busqueda por si la plantilla no me sirve.

      Gracias

      Fredy

Mostrando 2 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad