Quitar index.php en 000webhost (sin solucionar)

Diseño web Joomla Foros Joomla 1.5 Componentes Quitar index.php en 000webhost (sin solucionar)

  • Este debate tiene 10 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 9 años, 9 meses por Anónimo.
Mostrando 10 respuestas a los debates
  • Autor
    Entradas
    • #91042
      Anónimo
      Invitado

      Hola, mi web es http://waka.comule.com/i/ , alojo en 000webhost.com y quiero quitar el dichoso index.php, fui a configuración global -> Parámetros de optimización de SEO y activé “URLs amigables para motores de búsqueda ” y “Usar Apache mod_rewrite” cambié htaccess.txt por .htaccess y me salen las direcciones como noticias como waka.comule.com/i/noticias pero me da error al acceder.

      Leí por ahí que webhost usaba apache, ¿puedo hacer algo o tendré que soportar el index.php en este servidor?

    • #91049
      Anónimo
      Invitado

      Ciao

      En el ,htaccess has:

      Activado # RewriteEngine On (queda RewriteEngine On)?
      En la zona Begin – Joomla! core SEF Section has activado rewriteCond y el mandato RewriteRule quitandoles la almohadilla que tienen delante?

    • #91059
      Anónimo
      Invitado

      Hola! el .htaccess está así, cómo debería de estar?

      ##
      # @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
      # @package Joomla
      # @copyright Copyright (C) 2005 – 2010 Open Source Matters. All rights reserved.
      # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
      # Joomla! is Free Software
      ##

      #####################################################
      # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
      #
      # The line just below this section: ‘Options +FollowSymLinks’ may cause problems
      # with some server configurations. It is required for use of mod_rewrite, but may already
      # be set by your server administrator in a way that dissallows changing it in
      # your .htaccess file. If using it causes your server to error out, comment it out (add # to
      # beginning of line), reload your site in your browser and test your sef url’s. If they work,
      # it has been set by your server administrator and you do not need it set here.
      #
      #####################################################

      ## Can be commented out if causes errors, see notes above.
      Options +FollowSymLinks

      #
      # mod_rewrite in use

      RewriteEngine On

      ########## Begin – Rewrite rules to block out some common exploits
      ## If you experience problems on your site block out the operations listed below
      ## This attempts to block the most common type of exploit `attempts` to Joomla!
      #
      ## Deny access to extension xml files (uncomment out to activate)

    • #91063
      Anónimo
      Invitado

      Ciao

      te falta la mitad, como que el sef te lo gestiona Joomla añadele esto:
      [b]RewriteBase /

      ########## Begin – Joomla! core SEF Section
      ############# Use this section if using ONLY Joomla! core SEF
      ## ALL (RewriteCond) lines in this section are only required if you actually
      ## have directories named ‘content’ or ‘component’ on your server
      ## If you do not have directories with these names, comment them out.
      #
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional – see notes##
      RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$ [NC]
      RewriteRule ^(content/|component/) index.php
      #
      ########## End – Joomla! core SEF Section[/b]
      Si en el futuro te descargas un componente sef (sh404, artio, etc…) tendrás que añadir otra parte de unas 12 lineas

    • #91111
      cvg-masterKevin Mamaqi
      Participante

      Edita tu robots.txt

      añade al final:

      disallow: /index.php

    • #91136
      Anónimo
      Invitado

      perdona estaba entero

      está así
      ##
      # @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
      # @package Joomla
      # @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
      # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
      # Joomla! is Free Software
      ##

      #####################################################
      # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
      #
      # The line just below this section: 'Options +FollowSymLinks' may cause problems
      # with some server configurations. It is required for use of mod_rewrite, but may already
      # be set by your server administrator in a way that dissallows changing it in
      # your .htaccess file. If using it causes your server to error out, comment it out (add # to
      # beginning of line), reload your site in your browser and test your sef url's. If they work,
      # it has been set by your server administrator and you do not need it set here.
      #
      #####################################################

      ## Can be commented out if causes errors, see notes above.
      Options +FollowSymLinks

      #
      # mod_rewrite in use

      RewriteEngine On

      ########## Begin - Rewrite rules to block out some common exploits
      ## If you experience problems on your site block out the operations listed below
      ## This attempts to block the most common type of exploit `attempts` to Joomla!
      #
      ## Deny access to extension xml files (uncomment out to activate)
      #
      #Order allow,deny
      #Deny from all
      #Satisfy all
      #
      ## End of deny access to extension xml files
      RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
      # Block out any script trying to base64_encode crap to send via URL
      RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
      # Block out any script that includes a tag in URL
      RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
      # Block out any script trying to set a PHP GLOBALS variable via URL
      RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
      # Block out any script trying to modify a _REQUEST variable via URL
      RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
      # Send all blocked request to homepage with 403 Forbidden error!
      RewriteRule ^(.*)$ index.php [F,L]
      #
      ########## End - Rewrite rules to block out some common exploits

      # Uncomment following line if your webserver's URL
      # is not directly related to physical file paths.

      # Update Your Joomla! Directory (just / for root)

      # RewriteBase /

      ########## Begin - Joomla! core SEF Section
      #
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteCond %{REQUEST_URI} !^/index.php
      RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$ [NC]
      RewriteRule (.*) index.php
      RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
      #
      ########## End - Joomla! core SEF Section

      [quote]
      Edita tu robots.txt

      añade al final:

      disallow: /index.php
      sigue igual

    • #91140
      Anónimo
      Invitado

      Ciao

      Ostras que cosa más complicada, yo de ti volvería al original de Joomla, prueba con esto:

      ##
      # @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
      # @package Joomla
      # @copyright Copyright (C) 2005 – 2008 Open Source Matters. All rights reserved.
      # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
      # Joomla! is Free Software
      ##

      #####################################################
      # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
      #
      # The line just below this section: ‘Options +FollowSymLinks’ may cause problems
      # with some server configurations. It is required for use of mod_rewrite, but may already
      # be set by your server administrator in a way that dissallows changing it in
      # your .htaccess file. If using it causes your server to error out, comment it out (add # to
      # beginning of line), reload your site in your browser and test your sef url’s. If they work,
      # it has been set by your server administrator and you do not need it set here.
      #
      #####################################################

      ## Can be commented out if causes errors, see notes above.
      Options +FollowSymLinks

      #
      # mod_rewrite in use

      RewriteEngine On

      ########## Begin – Rewrite rules to block out some common exploits
      ## If you experience problems on your site block out the operations listed below
      ## This attempts to block the most common type of exploit `attempts` to Joomla!
      #
      # Block out any script trying to set a mosConfig value through the URL
      RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
      # Block out any script trying to base64_encode crap to send via URL
      RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
      # Block out any script that includes a tag in URL
      RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
      # Block out any script trying to set a PHP GLOBALS variable via URL
      RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
      # Block out any script trying to modify a _REQUEST variable via URL
      RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
      # Send all blocked request to homepage with 403 Forbidden error!
      RewriteRule ^(.*)$ index.php [F,L]
      #
      ########## End – Rewrite rules to block out some common exploits

      # Uncomment following line if your webserver’s URL
      # is not directly related to physical file paths.
      # Update Your Joomla! Directory (just / for root)

      RewriteBase /

      ########## Begin – Joomla! core SEF Section
      ############# Use this section if using ONLY Joomla! core SEF
      ## ALL (RewriteCond) lines in this section are only required if you actually
      ## have directories named ‘content’ or ‘component’ on your server
      ## If you do not have directories with these names, comment them out.
      #
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional – see notes##
      RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$ [NC]
      RewriteRule ^(content/|component/) index.php
      #
      ########## End – Joomla! core SEF Section

      y nada más…

    • #91166
      Anónimo
      Invitado

      nada, igual, este joomla lo acabo de instalar

    • #91167
      Anónimo
      Invitado

      Ciao

      Veo que ya te funciona el sitio, el otro dia cuando salía de la portada daba un error 400.

    • #91171
      Anónimo
      Invitado

      error 404¿ pues lo unico que he hecho en estos dias es modificar la plantilla y a veces me daba el 500 pero no se… bueno de todas formas gracias por todo

    • #100421
      Anónimo
      Invitado

      Hola a todos, yo tambien tenia problemas al intentar quitar el index.php en 000webhost (hosting gratuito)

      Ami me funciono quitando el comentario de RewriteBase.

      Estaba asi:

      # RewriteBase /

      Lo cambie asi:

      RewriteBase /

      Espero que les sirva a todos, a mi me funciono

      Saludos.

Mostrando 10 respuestas a los debates
  • El foro ‘Componentes’ está cerrado y no se permiten nuevos debates ni respuestas.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad