Quitar el texto y link “Ampliar” en detalles del producto

Diseño y Posicionamiento Web con Joomla Foros Componentes Especiales Virtuemart Quitar el texto y link “Ampliar” en detalles del producto

  • Este debate tiene 4 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 10 años, 2 meses por Anónimo.
Mostrando 4 respuestas a los debates
  • Autor
    Entradas
    • #100642
      blankAnónimo
      Invitado

      Hola,
      ¿Cómo puedo eliminar el texto “AMPLIAR IMAGEN” y también el link… que aparece en los detalles del producto?
      Gracias
      Adjunto una muestra

      Attachments:

    • #101886
      blankAnónimo
      Invitado

      Hola buenas !!
      pudiste solucionar este problema?? me gustaría que me dijeras como lo has hecho!!
      Muchas gracias.

    • #101888
      blankAnónimo
      Invitado

      Todavía NO,
      si encuentro la solución la publicaré aquí y si la encuentra tú haz lo mismo ¿OK?
      Saludos

    • #101890
      robertRobert
      Participante

      Se quita editando los archivos del theme virtuemart en /components/com_virtuemart/themes . Ahi te encontraras al theme default pero creo que ese no es. Si no me equivoco es un theme de http://www.vmjunction.com
      Pueden utilizar el Notepad ++ para encontrar el codigo

    • #102822
      blankAnónimo
      Invitado

      Hola, me he encontrado con este mismo problema y te cuento con la solución que he encontrado hace tan solo unos minutos. Es un poco bestia pero a mi me funciona.

      Editar el fichero theme.php de tu plantilla de VirtueMart, en mi caso es la classic_1

      componentscom_virtuemartthemesclassic_1theme.php

      Buscar la función vmBuildFullImageLink, que es la encargada de devolver el elemento imagen de producto que incluye el link para ampliación.

      Justo al final de la función, antes de la instrucción de retorno, añadir:

      $product_image = ps_product::image_tag($product[‘product_thumb_image’], $img_attributes, 1); // Línea añadida
      return $product_image;
      }

      Es decir, invalidamos toda la función vmBuildFullImageLink y forzamos a devolver tan solo la imagen sin el link de ampliación.

      Espero que pueda servirle a alguien de ayuda.

      Saludos

Mostrando 4 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver
Privacidad