Error Internet Explorer 8 mootools

Diseña tu página web con Joomla ¡ En 6 pasos ! Foros General Joomla en General Error Internet Explorer 8 mootools

Mostrando 6 respuestas a los debates
  • Autor
    Entradas
    • #89050
      Anónimo
      Invitado

      Estoy acabando una web con joomla 1.5, plantilla zeolite

      Con internet explorer 8 salen 2 errores “Listo pero con errores en la pagina” en principio la web funciona correctamente, los 2 errores son:

      Mensaje: El objeto no acepta esta propiedad o método
      Línea: 164
      Carácter: 9
      Código: 0
      templates/zeolite/ja_menus/ja_moomenu/ja.moomenu.js

      Mensaje: El objeto no acepta esta propiedad o método
      Línea: 59
      Carácter: 102
      Código: 0
      media/system/js/mootools.js

      Buscando por internet veo más gente con estos problemas en mootools, pero no encuentro como solucionarlo

      Gracias y saludos a todos….

    • #89063
      redloModerador Foro
      Participante

      El problema es el javascripts. IE6,7 y 8 no son muy amigos de javascripts. Yo hablaria con el creador de esa plantilla a ver que hay que modificar de esos archivos o bien si tiene un foro preguntaria ahi. No es que quiera que no preguntes, pero como no des con un programador de javascripts, lo vas a tener dificil. A no ser que este enlace te sirva –> https://solojoomla.com/foro/plugins/rto-como-hacer-que-mootools-funcione-en-joomla-1.5x.html

    • #89064
      redloModerador Foro
      Participante
    • #91299
      Anónimo
      Invitado

      Hola a todos, se que no es lo ideal retomar temas pasados.
      Pero estoy seguro ayudara a muchos con este problema, y es que al igual que el creador de este post yo igual tenia problemas con el mootols de joomla y es que que aun utilizando la ultima versión de JOOMLA 1.5.18 la version de mootools sigue siendo la versión 1.12 (versión desfasada) siendo la actual 1.2.4, todos conocemos lo caprichoso que IE en sus espantosas presentaciones y que desgraciadamente el comun denominado utiliza este explorador.

      Bueno asi que tal cual, para solucionar el error
      Descarguen la última versión disponible de mootools de la pagina oficial: http://mootools.net/download
      Y reemplasenlo por el que viene por default en JOOMLA (media/system/js/mootools.js)

      Y………. LISTO SOLUCIONADO, a mi me A solucionado toda la cadena de problema que me jalaba.
      ARRIBA FIREFOX

    • #91300
      Anónimo
      Invitado

      redlo escribió:

      El problema es el javascripts. IE6,7 y 8 no son muy amigos de javascripts. ..l

      Ciao

      Y menos de los scripts asincronos (Ajax), Google Analytics a debido cambiar su script asincrono porque en ie6 y 7 no se abría la página

    • #93331
      Anónimo
      Invitado

      Es cierto que IE, en cualquiera de sus versiones, siempre resultará más limitado frente a aplicaciones externas, es lo que tiene ir en contra de la corriente del código abierto y la estandarización – peor para Microsoft… Pero eso mejor dejarlo para otro post ;).

      Respecto al tema del mootools, funcionan bien con joomla 1.5 en adelante (aunque los upgrades no acaban de cuajar cuando hay otros plugins de por medio). Muchas veces he obtenido ese error pero siempre se debía a una modificación mia. Por ejemplo, debes comprobar los ajustes de la propia plantilla (en las plantillas JA tienes un cpanel o puedes usar el css, xml o el index); esto es, asegúrate de que no vienes de ajustes de otra plantilla (y si es así, asegúrate que valen para la actual), que los menús están correctamente asignados (puedes haber cambiado el nombre de los menús y como la plantilla asigna automáticamente estos nombres a los que da joomla por defecto… pues eso, te saltan errores de que no encuentra lo que debería estar ahí :D), etc, etc.

      Parece mentira pero siempre son los errores más tontos los que nos traen más de cabeza y los tenemos tan cerca que no los vemos :S…

      Pienso como thearcher y aunque hayan pasado varios meses, ésto puede valerle a alguien en el futuro.

      Saludos y suerte

      PD: Enhorabuena, gran foro!!

    • #93333
      redloModerador Foro
      Participante

      Corrrrrecto. Si sr asi es. Siempre repito que antes de ponerte a tocar nada, modificar codigo y demas, busques lo mas probable, que en joomla suele ser la solucion mas obvia y sencilla. Vamos, que como bien dicen. “Si es un lobo, me come” jejeje. Bienvenido seas, con esta claridad de pensamiento, a este foro.

Mostrando 6 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad