Actualizar version Joomla 1.7 a Joomla 2.5

Para actualizar de Joomla 1.7.x a Joomla 2.5.0 hay varias opciones. La mas sencilla, la que he utilizado y siempre me ha funcionado es la que a continuación mostrare. Evidente es que las extensiones de joomla 1.7 deben estar programadas bajo las reglas del MVC de joomla 1.7, si queremos evitar posibles problemas…

Una vez estemos seguros que las extensiones instaladas estan debidamente actualizadas, pasaremos a buscar la ultima actualizacion de joomla 1.7 que es joomla 1.7.4. Para no fallar, si desconoces tu  version actual te descargas la actualizacion de joomla 1.7.0 a 1.7.4. Una vez hemos actualizado a joomla 1.7.4, desde Extensiones / Gestor de extensiones pinchamos en Actualizar . Ahi nos mostrara que version tenemos. La señalamos y hacemos clic en el icono “Actualizar” para que llame al archivo XML en http://update.joomla.org/core/extension.xml.

Una vez actualizado, limpiaremos la cache y seguidamente pulsaremos CTRL+F5, lo que refrescara la cache de nuestro navegador. Basicamente se hace para que las imagenes e iconos del cuadro Quick icons del panel de nuestro administrador se ordenen y no salgan de forma incorrecta en sentido vertical.

Lo siguiente es desintalar el idioma español de la version joomla 1.7 desde Extensiones / Gestor de extensiones, y pincharemos en la pestaña “Gestionar” y se presentaran los distintos desplegables con sus opciones. Seleccionaremos el desplegable “Seleccionar Tipo” y seleccionando “Idioma” se nos mostrara los idiomas actuales.

Seleccionamos las dos opciones de idioma español de administracion y Sitio y pincharemos en el icono “Desinstalar“. Si el idioma predeterminado es el mismo, no nos dejara desintalarlo, por lo que tendremos que seleccionar otro idioma desde Extensiones / Gestor de idiomas, como por ejemplo el ingles como predeterminado para administracion y parte publica, luego procederemos a desinstalar el idioma español como lo he mencionado. Luego, logicamente procederemos a instalar el idioma español de la version joomla 2.5.

Si surge algun problema con la base de datos, como la no actualización de alguna tabla, iremos de nuevo a Extensiones / Gestor de extensiones y pincharemos en “Base de datos” y pincharemos en el icono “Corregir“, lo que deberia subsanar el problema.

Como siempre, espero les sea util.

11 comentarios en «Actualizar version Joomla 1.7 a Joomla 2.5»

  1. error al instalar…
    alguein sabe como dejar en verde cuando se instala la version 2.5 de joomla las dobles comillas y el mostrar errores, de momento me aparecen en rojo (que ahora mismo no se si es que stan activados o desactivado) pero si que estan en rojo y me pueden traer mas de un problema serio. Un saludo gracias.

  2. No deberia
    Segun los cambios efectuados de 1.7 a 2.5 [b]no deberian existir problemas[/b]. Ya he pasado siete diferentes sin problemas.
    [quote name=”fox2099″]Oye y ya se sabe algo sobre que pasara con los template.. en la version 2.5 como paso cuando se paso de 1.6 a 1.7 que alguna splantillas tenian problemas?[/quote]

  3. Nuevas funciones
    Te consteste en el foro > [url]https://solojoomla.com/foro-joomla/20-joomla-en-general/24768-nuevas-caracteristicas-de-joomla-2-5[/url]
    [quote name=”PepeCordoba”]No entiendo por que hay que desinstalar el idioma.[/quote]

  4. plamtilla de administracion fallo.
    Comento.. me dio problemas en el template pero de la administracion en un sitio, la base de datos en la parte de plantillas administrativas se daño y se creo como 8 platillas clonesy no fncionaba la que estab como predeterminada en la adminsitracion la cambie pror la minima de la marca rocket theme y ya jalo todo bien. la(s) otra tuve que borrarla(s), no servia(n).. esto paso tras la actualizacion. pd. y si trate de reparar base de datos como comenentas en este texto, pero nada. Espero que esto no tenga mas problemas mas adelante.

  5. plamtilla de administracion fallo.
    aaaaaaaaaaaaaaa me la aplico otra vez.. el error dice : Pro favor haga una seleccion de la lista. y todo lo que quequeiro seleccionar,e ditar, cambiar, borrar.. no puedo en la administracion. me lleva!!

  6. Activar allow_url_fopen en php.ini
    Es una funcion que se activa desde el archivo PHP.INI. Ahora bien, si no tienes acceso al php.ini o no esta incluido en el archivo, a ver si te sirve esto >
    nexxuz.com/configurar-php-ini-allow_url_fopen-en-hosting-desde-el-cpanel.html

    [quote name=”albarracin”]Hola, no puedo actualizar, ya que en “solapa actualizaciones” me aparece esto, y si le doy click a “actualizar” me aparece esto La configuración de PHP allow_url_fopen está desactivado. Este ajuste debe ser habilitado para que el programa de actualización trabaje. como puedo resolverlo? gracias[/quote]

Deja un comentario

Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de sus datos para estos propósitos. Ver
Privacidad